
Adobe Premiere Pro CS6 Project 6 guide
How to apply and adjust video keying effects
You can use video keying effects in a variety of ways to make portions of clips transparent so you can see clips below 
the keyed clips in a sequence. Adobe Premiere Pro CS6 has a variety of video effects that fall into four basic groups:

• Chroma/Color: Blue Screen (Windows only), Chroma (Windows only), Color, Non Red, and RGB Difference 
(Windows only). These all work in basically the same way. Replace a color in a clip with transparency.

• Luminance: Luma makes dark or light areas in a clip transparent or opaque, depending on the options you select.

• Opacity: Alpha Adjust simply changes the opacity of a clip.

• Matte: Difference, Image, Remove, Track, and three garbage matte effects (four-point, eight-point, and sixteen-
point). Matte keys typically use a graphic or some other user-defined region to do the equivalent of cutting a hole 
in a clip or making everything transparent outside of a user-defined area.

We recommend that you complete the “How to use the Motion effect” and “How to apply and adjust video effects” 
guides before completing the tasks in this guide. Those guides cover effect properties, which are used extensively in 
this guide. We also recommend that you complete the “How to work with alpha channel transparencies” guide. It 
introduces compositing: the process of creating a compound image by superimposing one or more clips on another 
clip, a technique used throughout this guide. We also recommend you complete the “How to build text and objects in 
the Titler” guide. It explains how to use the Titler to create graphics, a skill used in the final two tasks of this guide.

To complete the tasks in this guide, you need several video or still image clips with the following characteristics:

• A subject in front of a solid color background that does not match any colors on the subject (otherwise, those 
colors will become transparent along with the background)

• A subject in high contrast to the background (the full moon in the night sky, for example)

• A video clip with some action (a car driving by, someone running, a ball in flight)

• Clips to serve as backgrounds on which you layer the clips that use keying effects

Using chroma/color keying effects (Windows only)
Each chroma/color keying effect has its own set of properties. In general they let you adjust the color range to make 
transparent. The blue screen and color keys work with specific industry-standard colors. For the others, you choose 
from a wider spectrum of colors. You work with the chroma key and the color key in this guide. We suggest you try 
some other effects as well. In particular, try the Color Key options to help clean up the border between the transparent 
and opaque portions of a clip.

To use the Chroma Key effect:

1. Start Adobe Premiere Pro and import two clips: a 
background clip and a clip with a subject in front of a 
solid color background.

Note: Two clips are used as examples in this task 
(Figure 1). The Chroma Key effect will make the blue 
sky transparent to let the sunset show through. Figure 1 Clips used in this task
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2. Drag the clip you are using as a background to the Video 
1 track. Drag the clip with the subject in front of a solid 
color background to Video 2 directly above the clip on 
Video 1 (Figure 2).

Make sure the CTI is on those clips so you can view them 
in the Program Monitor.

3. In the Effects panel, expand the Video Effects bin, 
expand the Keying bin, and drag Chroma Key to the clip 
on Video 2.

4. In the Effect Controls panel, expand Chroma Key to view 
its options (Figure 3).

Note: Chroma Key has seven options. For detailed 
explanations of these and other effect options, refer to 
Adobe Premiere Pro Help.

5. Select the eyedropper next to Color. In the Program 
Monitor, Ctrl-click (Windows) or Command-click (Mac 
OS) in the solid color background to select the color you 
want to make transparent (Figure 4).

The selected color appears in the Chroma Key Color 
color swatch in the Effect Controls panel.

Note: By default, the eyedropper selects a color from a 
single pixel. Frequently that single pixel does not 
represent the average color of the region you want to key 
out, leading to less-than-satisfactory keying results. 
When using the eyedropper to get a color sample for a 
keying effect, Ctrl-click (Windows) or Command-click 
(Mac OS) to increase the subsample area to 5 x 5 pixels.

6. In the Effect Controls panel, drag the Similarity slider to 
the right until the solid color region becomes transparent 
and the background clip on Video 1 shows through 
(Figure 5).

7. In the Effect Controls panel, select Mask Only.

The subject (the opaque part of the clip) changes to a 
white silhouette (Figure 6).

8. Adjust the Similarity slider until you see only a few tiny 
holes (or no holes) in the silhouette.

Note: Using the View Zoom Level in the Program 
Monitor can help you fine-tune this and other color/
chroma key effects. Use it to zoom in on the image to get 
a closer look at the boundary between the subject and the 
keyed-out transparent background. Then make minor 
adjustments to Similarity and other options.

9. When you’re satisfied with the option values you’ve set, 
deselect Mask Only.

Figure 2 Sequence with two clips

Figure 3 Effect Controls panel, Chroma Key effect

Figure 4 Eyedropper

Figure 5 Clip with Chroma Key effect applied

Figure 6 Mask Only option applied
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Using the Color Key effect
The Color Key effect is a relatively low-budget but professional method for keying. To use this effect, you need to 
shoot your video in front of a solid color backdrop. It works well with industry-standard green screens and just about 
any other solid-color. The Color Key effect has replaced the Green Screen Key effect that was in previous versions of 
Adobe Premiere Pro.

To use the Color Key effect:

1. Import a background clip and a video with a solid 
background.

Note: Two clips are used as examples in this task 
(Figure 7). The Color Key will make the green 
background behind the subject transparent so the blue 
and red animated background shows through.

2. Drag the background clip to Video 1 and the green-screen 
clip to Video 2 above the clip on Video 1 (place them 
after the clips already on the sequence).

3. In the Effects panel, expand the Video Effects bin, 
expand the Keying bin, and drag the Color Key to the clip 
on Video 2.

The clip with the green background should be visible in 
the Program monitor.

4. In the Effect Controls panel, expand the Color Key effect 
options (Figure 8).

5. Click the Key Color eye dropper to select it (Figure 8).

6. Position the eye dropper over the clip’s green background 
in the Program monitor. Click to select the green 
background as the key color.

The green is made transparent and the background clip 
shows through, but the key may still require some fine 
tuning (Figure 9).

7. Adjust the Color Tolerance, Edge Thin, or Edge Feather 
settings to create a solid silhouette with a sharp contrast 
between the subject you are not keying out and the 
background clip below it in the sequence (Figure 10).

Note: Often you want to make the subject, which you’ve 
shot with a key in mind, the focal point of your 
composited clip. One way to ensure that happens and to 
give your keyed shots a realistic look is to blur the 
background you insert in the transparent areas created by 
the key effect so the subject stands out. If your 
background is not already a bit out of focus, use the Fast 
Blur video effect on it.

Figure 7 Clips used in this task

Figure 8 Effect Controls panel, Color Key effect

Figure 9 The key still needs fine tuning

Figure 10 Clip with Color Key adjusted

Color Key eye dropper (color selector)
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Using the Luma Key
The Luma Key creates transparencies by using clip brightness values. You can use it to make dark or bright regions of 
a clip become transparent or opaque.

To use the Luma Key:

1. Import a background clip and a clip with bright or dark 
areas that you want to make transparent.

Note: Two clips are used as examples in this task  
(Figure 11). The Luma Key will make the dark 
background behind the starfish transparent and replace it 
with a sunset.

2. Drag the background clip to Video 1 and the clip with the 
contrasting subject and background to Video 2 (place 
them after the clips already on the sequence).

3. In the Effects panel, expand the Video Effects bin, 
expand the Keying bin, and drag the Luma Key to the 
clip on Video 2.

4. In the Effect Controls panel, expand the Luma key 
properties. Adjust Threshold and Cutoff to make the 
background become transparent (Figure 12) and 
(Figure 13). 

There is no mask-only option in this effect so finding 
suitable settings is a little more difficult.

Note: Once you key out a background, you can apply the 
Drop Shadow video effect to the portion of the clip 
subject that did not key out. The example (Figure 14) 
shows how that can work with two clips:

a. Use the Motion effect to move the opaque portion of 
the clip and change its size.

b. Apply the Drop Shadow effect to the clip. (Drop 
Shadow is in the Video Effects Perspective bin.)

c. In the Project panel, drag another instance of that 
clip to Video 3 above the clips on Video 1 and Video 
2.

d. Click the clip on Video 2 and select Edit > Copy.

e. Click the clip on Video 3 and select Edit > Paste 
Attributes. The effects applied to the clip on Video 2 
(Luma Key, Motion, and Drop Shadow) are applied 
to the clip on Video 3.

f. Use Motion on the Video 3 clip to move it to the 
lower-right part of the screen and rotate it 90 
degrees.

g. Change the Drop Shadow Direction value to have 
the shadow fall at the correct angle to match the drop 
shadow on the first clip.

Figure 11 Two clips used in this task

Figure 12 Effect Controls panel, Luma Key effect

Figure 13 Clip with Luma Key applied

Figure 14 Clips with Luma Key, Motion, and Drop 
Shadow applied
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Using matte keys
Matte keys cut “holes” in one clip to allow portions of another clip to show through. They can also create something 
like cutout figures you can place on top of other clips.

The nomenclature can be confusing. Matte keys are not the same as color mattes (color graphics). However, matte 
keys generally use matte graphics you create to define the areas you want to make transparent or opaque.

There are two basic types of matte keys:

Garbage: Four-, eight-, or sixteen-sided polygons. They’re called garbage keys because you typically use them to 
remove something you don’t want in the video. You can also use them to outline something you want to place on 
another clip. You move their vertices to define the outline of the area you want to display.

Graphic: Uses a graphic—usually a shape you want to key out or key in. These keying effects include Difference, 
Image, Remove, and Track.

In this task you work with the Sixteen-Point Garbage Matte Key and the Track Matte Key.

To use a garbage matte key:

1. Import a background clip and a clip with an object you 
want to isolate.

2. Drag the background clip to Video 1 and drag the clip 
with an object you want to isolate to Video 2 above the 
clip on Video 1 (place them after the clips you worked on 
in previous tasks).

3. In the Effects panel, expand the Video Effects bin, 
expand the Keying bin, and drag the Sixteen-Point 
Garbage Matte Key to the clip on Video 2.

4. In the Effect Controls panel, expand the Sixteen-Point 
Garbage Matte properties, and click its Transform button 
(Figure 15).

Sixteen cross-hair handles appear in the Program Monitor 
(Figure 16).

Figure 15 Effect Controls panel, Sixteen-Point 
Garbage Matte effect

Figure 16 Program Monitor with Sixteen-Point 
Garbage Matte cross-hair handles

Transform button

Cross hair 
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5. Drag the 16 handles to make a rough outline of the object 
you want to isolate (Figure 17).

6. In the Program Monitor, in the Select Zoom Level menu, 
select a value to move in closer to the object and then 
fine-tune the placement of the garbage matte vertices 
(Figure 18).

Figure 17 Clip with a garbage matte applied

Figure 18 Program Monitor with garbage matte 
cross-hair handles

Select Zoom Level 
menu
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Three garbage matte tips

Try the following tips when preparing for and using garbage mattes.

Garbage matte tips:

1. We used two instances of the cat clip to create the effect 
shown in the example (Figure 19). Here’s how we did 
that:

a. Added the second cat clip on Video 3 above the other 
two clips in the sequence.

b. Applied the garbage matte to the clip on Video 3 to 
isolate the other eye.

c. Used the Motion effect on both clips to adjust their 
size and position them on the moon clip.

2. Garbage mattes create sharply defined edges. To soften 
the edges of the clip to which you applied the garbage 
matte, apply a blur video effect.

3. You can use a garbage matte key to create a split-screen 
effect that allows the same actor to appear in two places 
at once. This takes some planning. Here’s how to do that:

a. Lock down your camcorder on a tripod.

b. Ensure that the lighting, camera focus, and exposure 
settings don’t change for the duration of the shoot.

c. Have an actor do a scene on one side of the set.

d. Have that actor play another role on the other side of 
the set. The actor shouldn’t cross the line that divides 
the set and there can’t be any movement (for 
example, waving palm trees or flying birds) in the 
vicinity of the scene’s dividing line.

e. In Adobe Premiere Pro, use a garbage matte on one 
of the scenes so the actor appears on both sides of the 
set at once.

Figure 19 Two clips with garbage matte effects 
applied
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Using the Track Matte Key
The Track Matte Key effect is applied to a clip on a video track and places a matte—a still image or graphic 
(including graphics created in the Titler)—on a separate track above that clip. The matte defines the areas of 
transparency in the selected clip and uses them to reveal whatever is below the selected clip in the sequence. 

The Track Matte Key uses the grayscale or alpha channel transparency values of the matte graphic to define the 
transparent areas in the clip the effect is applied to. (If the matte is in color, the track matte analyzes it as if it were 
grayscale). It can make white or black areas opaque or transparent, depending on the values you select in the effect 
properties area. The Track Matte Key makes gray areas semitransparent.

This is a tremendously useful effect, largely because you can animate the matte graphic. For example, you can use the 
Motion effect to gradually reveal the matte or to move it on the clip to follow action. The latter application of the 
Track Matte Key is called a traveling matte, which you will try a bit later. Just about every older movie involving 
“impossible” motion—spaceships, Superman in flight, or giant spiders—used traveling mattes.

To use the Track Matte Key:

1. Create a new title as follows (Figure 20):

a. Select File > New > Title.

b. Name the title Track Matte Graphic and click OK. 

c. In the Title Tools panel, select the Ellipse tool and 
drag in the Titler main pane to create a shape.

d. In the Title Properties panel, select Fill.

e. In the Fill Type menu, select Radial Gradient, 
change the color of the color stop on the right to 
black and its Color Stop Opacity value to about 20%.

f. Move the two color stop boxes until your graphic has 
a soft edge quality like the example (Figure 20).

g. Position the graphic about where you think it will 
overlap the subject in your video clip.

h. Close the Titler.

2. In the Project panel, drag a video clip to Video 1, a 
background clip to Video 2, and the Track Matte Graphic 
you just made to Video 3.

3. In the Effects panel, expand the Video Effects bin, 
expand the Keying bin, and drag the Track Matte Key to 
the Video 2 clip.

4. In the Track Matte Key options, do the following 
(Figure 21):

• In the Matte menu, select Video 3.

• In the Composite Using menu, select Matte Luma.

• Select Reverse (the ellipse is white, which the Track 
Matte normally sees as opaque, so selecting Reverse 
makes the white area of the ellipse transparent and 
the black area opaque).

Figure 20 Titler

Figure 21 Track Matte Key options
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Note: Normally, a clip in the highest video track covers 
what’s below it in a sequence. But when you select the matte 
video track, Adobe Premiere Pro automatically disables the 
portion of the track used in the Track Matte Key. Essentially, 
it makes that segment completely transparent and applies it to 
the clip with the Track Matte Key applied to it.

5. Change the Motion effect settings on the Video 3 Titler 
clip to position and change the size and shape of the 
graphic to suit your needs.

6. Use the Motion Scale parameter and keyframes on the 
clip in Video 3 to start the matte at zero percent and have 
it grow to its full size by about a second into the clip.

You can also apply video effects to the graphic clip in 
Video 3. For example, you can use the Fast Blur effect to 
further soften the edges of the matte. Your finished work 
should look something like the example (Figure 22).

Figure 22 Clip with Track Matte Key 

Making a traveling matte
You will use the Track Matte Key to create a traveling matte time and time again. A traveling matte is a great way to 
follow and highlight action. Traveling mattes have several uses. For example, you can use a tinted matte to highlight 
action or apply the Mosaic or Fast Blur video effect to conceal someone’s identity.

To complete this task you need a video clip with some action to highlight and follow.

To make a traveling matte:

1. Import the action video clip.

2. In the main menu, select File > New > Color Matte.

The New Color Matte dialog box appears. 

3. Click OK to accept the default settings.

The Color Picker appears (Figure 23).

4. Select an orange hue (or a color of your choice) and click 
OK.

The Choose Name dialog box appears.

5. In the Choose Name dialog box, give the color matte a 
name and click OK.

6. In the Titler, create a soft-edge rectangle (for instructions 
on how to do this, refer to step 1 of the previous task, 
“How to use the Track Matte Key”). Close the Titler.

Figure 23 Color Picker
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7. Drag four clips to a sequence (Figure 24):

• The action video clip to Video 1

• The action video clip to Video 3 (directly above its 
twin on Video 1)

• The color matte to Video 2 (between the two action 
clips)

• The rectangle graphic to Video 4 above the other 
three clips

8. Select the color matte clip in Video 2.

9. In the Effect Controls panel, change the Opacity value to 
35% (Figure 25).

The color matte is now semitransparent and you can use 
it to apply a tint to the rectangle that will highlight the 
action in Video 1. The matte opacity is not apparent yet 
because the video clip on Video 3 covers the color matte 
in Video 2.

10. In the Effects panel, expand the Video Effects bin, 
expand the Keying bin, and drag the Track Matte Key to 
the action video clip in Video 3.

11. In the Track Matte Key options area of the Effect 
Controls panel, do the following (Figure 26):

• In the Matte menu, select Video 4.

• In the Composite Using menu, select Matte Luma.

Your Program Monitor image should look something like 
the example (Figure 27).

12. Now use keyframes and set motion effect values for the 
traveling matte graphic on Video 4 so it follows and 
highlights the action. To do that, follow these steps:

a. Select the traveling matte graphic clip on Video 4.

b. Move the CTI to the beginning of the clip.

c. In the Effect Controls panel, switch on keyframes for 
Position, Scale Height, and Scale Width (deselect 
Uniform Scale).

d. Position and adjust the rectangle size to have it fit 
over the action figure.

e. Move the CTI a little way into the action clip.

f. Reposition and readjust the rectangle to fit over the 
action figure.

g. Do this enough times to have the rectangle stay on 
top of the motion for the length of the clip.

13. Play the video.

Figure 24 Traveling matte clip set-up

Figure 25 Effect Controls panel, Opacity effect 

Figure 26 Track Matte Key options

Figure 27 Video clip with a traveling matte
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Using the Ultra Key effect
The Ultra Key effect is ideal for fast, accurate keying on challenging footage. The Ultra Key is optimized for DV and 
HD footage that includes uneven lighting, wrinkled backgrounds, and frizzy hair. Ultra Key preserves shadows and 
can achieve complex keys on smoke, liquids, and transparent objects.

For example, suppose you’ve shot some footage of a skier in the woods on a cloudy day, but the scene is supposed to 
show the skier gliding down the mountain on a sunny day with blue sky. Using the Ultra Key effect, you can transport 
your skier to an entirely different scene.

Figure 28 Foreground and background video clips

To use the Ultra Key effect:

1. Import a video clip that you want to key and a second 
video clip or still image to use as the background.

2. In the Project panel, drag the background clip to Video 1 
and the foreground clip to Video 2. 

3. In the Effects panel, expand the Video Effects bin, 
expand the Keying bin, and drag the Ultra Key effect to 
the foreground clip in Video 1.

4. In the Effect Controls panel, expand the Ultra Key 
options (Figure 29). 

5. Click the Ultra Key eye dropper to select it (Figure 29). Figure 29 Ultra Key options

Ultra Key eye dropper
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6. Position the eyedropper over the foreground clip in the 
Program monitor. Click to select a color range that you 
want to make transparent. In this example, we selected 
the snow (Figure 30).

The snow in the foreground video clip becomes 
transparent leaving the trees and the skier superimposed 
over the background scene (Figure 31). The Ultra Key 
did a good job of removing only the snow, even between 
the fine lines of the tree branches and the blurred motion 
of the skier’s poles. 

7. In the Effects Control panel, expand the Matte 
Generation options and adjust the Transparency value up 
or down to change the key (Figure 32). 

Using the Ultra Key effect, it’s easy to get a very good 
key, even from the most challenging footage (Figure 33). 

As with any key effect, the best settings will vary, 
depending on your video. Continue to experiment with 
the Ultra Key options until you get the results you want. 

Figure 30 Program monitor

Figure 31  Keyed image with no adjustments

Figure 32  Ultra key Matte Generation options

Figure 33  Slight increase in transparency
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