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How to use the ruler, grid, guides, and the Align panel
Much of your job as a page designer is to place text and graphics on the page in a pleasing, organized 
way. Although you can do much of this placing by “eyeballing it”—using your judgment to position 
text and graphics—Adobe InDesign provides a number of tools to help you position objects in exact 
locations.

You may have encountered the grid and guides (and even a version of the Align panel) in Adobe 
Photoshop, Adobe Illustrator, or other Adobe products. If so, you will find that the grid and guides in 
InDesign differ slightly from those in the other programs. For example, InDesign automatically adds 
guides in default locations, whereas in Photoshop you need to manually add guides for specific use.

This document covers four tools (Figure 1) to help you position objects:

•	 Rulers
•	 Guides

•	 Grids
•	 The Align panel

Figure 1 Document window showing rulers, guides, grid and Align panel
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Using rulers

Rulers can be useful in figuring general placement. For 
example, if you want to place a logo 1 inch inside the edge 
of a business card, you can use the ruler to do so.

Rulers appear at the top and left edges of the workspace. 
(If you don’t see them, select View > Show Rulers). By 
default, the zero point of these rulers is at the top-left 
corner of your page, but you can change this zero point.

By default, rulers measure in picas. Pica is a print term—
one pica equals 12 points, in the sense of a 12-point font.

You can change the unit of measurement for the rulers to 
other units including points, inches, millimeters, 
centimeters, ciceros, agates, pixels, or custom 
measurement. When you do, all tabs, margins, indents, 
and other measurements appear in the unit of choice. To 
change units, choose Edit > Preferences > Units & 
Increments (Windows) or InDesign > Preferences > Units & 
Increments (Mac OS) and update the Ruler Units for horizontal 
and vertical rulers (Figure 2). 

Using guides

Guides are thin lines that aid with object placement. By default, InDesign adds two types of guides to your documents: 
margin guides and column guides. Margin guides show page edges; column guides indicate where columns fall. 

Ruler guides are similar to the guides in Photoshop and other Adobe tools. You can place ruler guides anywhere on the 
page and relocate them as you desire. You can also snap objects to guides. With snapping turned on, objects 
automatically click into place as you move them close to a guide. Guides can be useful for lining up objects on a page.

To add a guide:

1.	 Start InDesign and create a new document.

2.	 Make sure the rulers are visible. If the rulers are not 
visible, choose View > Show Rulers.

3.	 Drag from the horizontal ruler down into the docu-
ment to create a guide (Figure 3).

As you drag, the guide appears as a thin line (colored 
blue by default). 

As you drag, you can see the guide’s position on the 
vertical ruler. The vertical coordinate is also displayed 
beside the pointer. This can help you position the 
guide.

4.	 When you reach the 1-inch mark on the vertical ruler, 
release the mouse to drop the guide.

The guide is now available for your use.

Figure 3 Dragging a guide

Figure 2 Units & Increments section of the Preferences 
dialog box
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To snap objects to guides:

1.	 Choose View > Grids & Guides and confirm that  
Snap To Guides is selected.

2.	 Select the Rectangle tool in the Tools panel  
(Figure 4).

3.	 Drag in the document to draw a small rectangle.

4.	 Select the Selection tool in the Tools panel.

5.	 Click the edge of the rectangle you drew and drag it 
close to a guide.

As you do, you should see the rectangle jump to align 
with the guide (Figure 5). This is the effect of Snap To 
Guides.

Note: As you move a shape, the X and Y coordinate 
tool tip hints appear to help to best align the shape to 
the page. 
 
 

Figure 5 Object snapping to a guide

Figure 4 Rectangle panel

Selection tool

Rectangle tool
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Using the grid

A grid is a series of thin horizontal and vertical lines that overlay your entire page. Before desktop publishing tools, 
layout editors arranged copy and images on sheets of paper with such grids.

In InDesign, you can choose from two kinds of grids: a baseline grid for aligning columns of text and a document grid for 
aligning objects. On the screen, a baseline grid resembles ruled notebook paper and a document grid resembles graph 
paper. You can customize both kinds of grids.

Using the baseline grid
A baseline grid is useful for making sure your text lines up across columns. The baseline is the lower edge of text—the 
point of the lowest segment of letters except those that extend below the baseline, such as g and y.

To display a baseline grid, choose View > Grids & Guides > Show Baseline Grid. The idea is to keep the baselines of all 
text—both headings and body text—on the same increment.

A good idea is to set leading—the space between text lines—at the same increment as the baseline grid. For example, 
if you set the baseline grid to 14 points, you should also set leading to 14 points. This ensures that text lines align with 
the baseline grid, as in Figure 6. Keeping everything on the same baseline grid gives the page a clean, uniform 
appearance.

Using the document grid
The document grid is useful for aligning objects—not just text—across your document. You can use the document grid 
to make sure an image is at the same height as a heading, for example. Many designers find it useful to think of layout 
in terms of grids, with everything on the page placed on a grid. The document grid helps you align page objects with 
each other both vertically and horizontally.

In InDesign, you can customize both the baseline grid and the document grid in terms of spacing, line thickness, and 
color. You may find spacing helpful, especially if you know you’re arranging your page in, for example, half-inch 
increments. Line thickness and color are a matter of preference—they’re part of customizing your work environment. 
The grid does not appear in anything you print or publish; it’s for working purposes only. You can also snap objects to 
the grid. With snapping turned on, objects automatically click into place as you move them close to gridlines.

Figure 6 Baseline grid
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To use the document grid:

1.	 Choose Edit > Preferences > Grids (Windows) or 
InDesign > Preferences > Grids (Mac OS).

The Preferences dialog box appears, with the Grids 
section selected (Figure 7).

2.	 Deselect the Grids In Back option at the bottom of 
the dialog box.

This lets you see the grid over your document.

Under Document Grid, observe the settings for 
Horizontal and Vertical. By default, these should be 
set to the following:

•	 Gridline Every: 1 in.

•	 Subdivisions: 8

This means a major gridline appears every 1 inch, with 
the major grid subdivided 8 times, at 1/8-inch 
increments. 

Depending on the scale of your document, you might 
find it useful to increase the size of these settings.

3.	 Click OK.

The Preferences dialog box closes.

4.	 Choose View > Grids & Guides > Show Document 
Grid.

The document grid appears over your document 
(Figure 8).

You can now position objects in the document along 
this grid. Of course, once you position your objects, 
you may want to hide the document grid to see your  
work better.

Snapping objects to the grid
You can make the grid even more useful by setting objects to snap to the grid. With Snap To Document Grid turned on, 
objects are automatically positioned along grid lines.

To snap objects to the grid:

1.	 Choose View > Grids & Guides > Snap To Document Grid.

2.	 Select the Rectangle tool in the Tools panel.

3.	 Drag in the document to draw a small rectangle.

4.	 Select the Selection tool in the Tools panel.

Figure 7 Preferences dialog box, Grids section

Figure 8 Document grid applied

Grids In Back option
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5.	 Click the edge of the rectangle you drew and drag it 
somewhere else in the document. 

As you do, the rectangle clings to the grid (Figure 9). 
This is the effect of Snap To Document Grid setting.

X and Y coordinate tool tip hints are available to help 
you position the shape on the page.

Using the Align panel

The Align panel (Figure 10) offers a series of tools for arranging objects in relation to each other, to the page, to the 
page’s margins, and to multipage spreads.

For example, by using the Align panel, you can locate a text box in the exact horizontal center of a page or align it with 
the left margin. You can even select three text boxes and distribute them evenly across the left margin. Again, you 
could do some of this by hand, but the Align panel can save you lots of time.

The Align panel has two sets of options:

•	 Align Objects: Arrange objects along a vertical or horizontal line.

•	 Distribute Objects: Even out the spaces between a series of objects.

For each of these, you can choose one of five Align To options:

•	 Align to selection

•	 Align to a key object

•	 Align to margins

•	 Align to page

•	 Align to spread

Figure 9 Object snapping to grid

Figure 10 Align panel with Align To options
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The table describes how Align Objects and Distribute Objects work with these options.

Align to selection Align to a key object Align to page Align to spread Align to spread

Align Objects Rearranges objects 
along left edge, right 
edge, top edge, 
bottom edge, 
vertical center, or 
horizontal center.

Rearranges objects 
in relation to a 
selected object’s  
left edge, vertical 
center, and so on.

Rearranges objects 
in relation to page’s 
left edge, vertical 
center, and so on.

Rearranges objects 
in relation to the 
entire pagespread’s 
left edge, right edge, 
top edge, or bottom 
edge or in the center 
of the spread.

Rearranges objects in 
relation to the entire 
pagespread’s left edge, right 
edge, top edge, or bottom 
edge or in the center of the 
spread.

Distribute 
Objects

Distributes three or 
more selections 
according to left 
edge, right edge, top 
edge, bottom edge, 
vertical center, or 
horizontal center. 
Edges are 
determined by the 
bounding box 
enclosing each 
selected object.

Distributes three or 
more selections 
according to a 
selected  objects’s 
left edge, right edge, 
top edge, bottom 
edge, vertical center, 
or horizontal center.

Distributes three or 
more selections 
according to left 
edge, right edge, top 
edge, bottom edge, 
vertical center, or 
horizontal center 
across the entire 
height (vertical) or 
width (horizontal) of 
the page.

Distributes three or 
more selections 
according to left 
edge, right edge, top 
edge, bottom edge, 
vertical center, or 
horizontal center 
across the entire 
height (vertical) or 
width (horizontal) 
across the spread.	

Distributes three or more 
selections according to left 
edge, right edge, top edge, 
bottom edge, vertical 
center, or horizontal center 
across the entire height 
(vertical) or width 
(horizontal) across the 
spread.

The Align panel helps you quickly create uniform, orderly arrangements of frames and shapes. For example, the frames 
in Figure 11 are haphazardly arranged. You can use the Align panel to arrange them in an orderly, organized manner.

To use the Align panel:

1.	 Select the Rectangular Frame tool in the Tools panel.

2.	 Drag in the document to create a small rectangular 
frame.

3.	 With the frame still selected, choose Edit > Duplicate.

Repeat to create several rectangular frames of 
identical size.

4.	 With the Selection tool, drag each frame and arrange 
the frames so they do not overlap each other.

5.	 Drag with the Selection tool until you have selected 
multiple objects (Figure 11).

Figure 11 Drag Selection Tool to select unaligned frames

Selection 
tool
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6.	 Choose Window > Object & Layout > Align to 
display the Align panel (Figure 10).

7.	 To align the left edges of the frames, select Align To 
Selection and then Align Left Edges (Figure 12). 
This command aligns the selected objects by their left 
edges. You can also choose to align objects with the 
left, right, or center of the page or to the left, right, or 
center between the margins.

8.	 To distribute the frames equally, select Align To 
Selection and then Distribute Vertical Centers. 
Observe that the spaces between pairs of frames are 
equal (Figure 13).

Figure 12 Left edges aligned

Figure 13 Frames evenly distributed
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